Legal Studio degraded service

Incident Report for Welocalize

Resolved

This incident has been resolved.
Posted Aug 07, 2026 - 01:40 UTC

Update

This issue has been resolved.
Posted Aug 07, 2026 - 01:40 UTC

Update

We are continuing to investigate this issue.
Posted Aug 06, 2026 - 21:31 UTC

Investigating

Legal Studio is currently experiencing degraded service due to an issue with a third-party provider, which may temporarily prevent you from starting new patent and litigation projects in the platform. Our team is aware and is making every effort to resolve this as quickly as possible.
Posted Aug 06, 2026 - 20:18 UTC
This incident affected: Legal Studio.