Problems accessing Workday production

Incident Report for Welocalize

Resolved

Workday confirms that the service has returned to normal.
Posted Mar 17, 2025 - 20:03 UTC

Investigating

Workday is reporting performance/system issues on their platform, impacting the Welocalize Workday production and sandbox tenants. Please be advised that Welocalize users are not able to access Workday at this time. Workday is working on a resolution.

We will post updates as we receive them from the Workday team.
Posted Mar 17, 2025 - 19:17 UTC
This incident affected: Workday.