Relay Slow Performance

Incident Report for Welocalize

Update

We are continuing to work on a fix for this issue.
Posted May 12, 2026 - 21:28 UTC

Identified

The root cause has been identified, and a fix is under way. We will update as soon as we have more information.
Posted May 12, 2026 - 21:28 UTC

Investigating

We are currently investigating reports of slow performance with Relay.
Posted May 11, 2026 - 13:30 UTC
This incident affects: Pantheon (Relay).