Citrix Share file not accessible
Incident Report for Welocalize
Resolved
Citrix has reported this issue as resolved.
Posted Mar 13, 2023 - 17:30 UTC
Update
We are continuing to investigate this issue.
Posted Mar 13, 2023 - 14:20 UTC
Investigating
There is a system-wide issue right now with Citrix Share File. This issue is on the Citrix side. As soon as we know more we will let you know.
Posted Mar 13, 2023 - 14:17 UTC
This incident affected: Citrix Sharefile.