Widespread internet outage (Cloudflare) currently affecting multiple Welocalize systems

Incident Report for Welocalize

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 10:25 UTC

Identified

A widespread internet outage (Cloudflare) is currently affecting access to a number of Welocalize systems including Zendesk and Workday. Cloudflare are currently working on a fix.
Posted Dec 05, 2025 - 09:16 UTC